Jump to content

InDesign CS6: Tabellen und ihre rätselhaften Formatierungen – Hiiilfe!


Kathrinvdm
Zur besten Antwort springen Solved by Ralf Herrmann,

Empfohlene Beiträge

Kathrinvdm

Liebe Kollegen, 

 

kürzlich hat es mir ein InDesign-Dokument mit jeder Menge Tabellen auf den Tisch geweht, welches ich im Auftrag des Kunden bearbeiten soll (siehe auch diesen Thread). Hauptsächlich geht es darum, kleine inhaltliche Korrekturen vorzunehmen, die auch kein Problem ist. Aber einige Tabellen sollen ganz neu hinzugefügt werden und als Vorlagen dafür habe ich Word-Tabellen erhalten. Und da beginnt das Problem. Die Word-Tabellen lassen sich nicht so platzieren, dass sie die im Dokument vorgegebenen Formatierungen sauber übernehmen. Ich nehme deswegen momentan an, dass ich am ehesten vorankomme, wenn ich eine der bestehenden Tabellen im InDesign-Dokument dupliziere und sie dann zu Fuß mit den neuen Inhalten fülle, so dass alle Text- und Tabellenformatierungen erhalten bleiben und ich diese nicht neu zuweisen muss. 

 

Das Dilemma an diesem Dokument ist, dass es in der Vergangenheit durch verschiedenen Hände gegangen ist und wohl auch schon Konvertierungen zwischen unterschiedlichen Layoutprogrammen hinter sich hat. Leider werde ich nur für einen Tag Korrekturen bezahlt, es besteht also keinerlei Chance, das Dokument (ein dicht bedruckter Gebührenkatalog von 110 Seiten) neu und sauber aufzubauen. 

 

Das Schriftendilemma habe ich ja bereits im oben genannten Thread thematisiert und es inzwischen mit Eurer Hilfe gelöst (nochmals danke!). Alle Schriften habe ich durch einheitlich neue OT-Fonts ersetzt und die Anzahl der Schnitte so weit wie möglich reduziert. Einige Schriftgrößenanpassungen musste ich vornehmen und sämtliche Absatz- und Zeichenformate auf die ersetzten Schriften umarbeiten (Leider passiert das nicht automatisch, wenn man Schriften im Dokument über »Schriftart suchen« ersetzt. Gibt es da vielleicht eine schlauere Lösung?). 

 

So, und nun zu meinem momentan dringendsten Rätsel!

 

Die Tabellenseiten sind jeweils mit einem Rahmen bestückt, in dem oben eine grau hinterlegte Headline steht, darunter sitzt eine Tabelle und unterhalb dieser finden sich zahlreiche Anmerkungen, das Kleingedruckte. Alles in einem Rahmen. Die Headline ist in linksbündigem Flattersatz gesetzt und ihre Zeilen sind – unabhängig von der eigentlichen Zeilenbreite – in voller Rahmenbreite hellgrau unterlegt und zwar so, dass die Hinterlegungen der einzelnen Zeilen eine durchgehende hellgraue Fläche ergeben.  

 

Markiere ich nun eine solche Headline, um sie durch einen zuvor in die Zwischenablage kopierten neuen Text zu ersetzen, dann klappt das zwar und das Zeichenformat wird auch korrekt übernommen, aber die graue Hinterlegung wird zerstört. Sie ist im Anschluss partiell verschwunden und ich bekomme nicht heraus, wie ich das wieder reparieren kann. Über Unterstreichungs- bzw. Durchstreichungsoptionen wurden diese grauen Hinterlegungen nicht erstellt, das habe ich schon nachgeschaut. Separat druntergelegt wurden die Flächen auch nicht, sie sind schon irgendwie an den Text gebunden – ich weiß bloß nicht wie! Himmel, wie blöd man sich vorkommen kann …

 

Weiß einer von Euch vielleicht die Lösung und wäre so nett, sie mit mir zu teilen?

 

Bisschen ratlose, dafür umso herzlichere Grüße,

Kathrin :-(  

Link zum Beitrag
Kathrinvdm

Ich darf das Dokument leider nicht aus der Hand geben – das musste ich unterschreiben. Aber ich versuche mal, das Problem neutral zu extrahieren und hier einzustellen …  :nicken:

Link zum Beitrag
Kathrinvdm

Okay, hier das Beispieldokument. Ich habe den Originalrahmen in dieses Dokument kopiert und rechts daneben den erneut kopierten Rahmen, in den ich einen Text aus der Zwischenablage kopiert habe. Da sieht man das Problem mit der fehlerhaften Hinterlegung ganz deutlich. Vermutlich kannst Du die Lösung gleich aus dem Hut zaubern – aber ich bekomme es alleine echt nicht raus!  :oops:

 

(Ich habe das Dokument wieder entfernt)

 

 

Link zum Beitrag
Kathrinvdm

Uaaah, diese verflixten Absatzformate! Das Dokument hat bestimmt 30 davon und zig Zeichenformate. Alles Kraut und Rüben! Tausend Dank Ralf – da habe ich den Wald vor lauter Bäumen nicht mehr gesehen …  :oops:  :gimmifive:

Link zum Beitrag
sabok

... Einige Schriftgrößenanpassungen musste ich vornehmen und sämtliche Absatz- und Zeichenformate auf die ersetzten Schriften umarbeiten (Leider passiert das nicht automatisch, wenn man Schriften im Dokument über »Schriftart suchen« ersetzt. Gibt es da vielleicht eine schlauere Lösung?). ...

 

 

 

Hallo

Wenn Du unten im Fenster "Schriftart suchen" das Häkchen setzt, werden die Schriften auch in den Absatz- und Zeichenformaten ersetzt. Größenänderungen musst du jedoch von Hand vornehmen.

 

Gruß sabok

Link zum Beitrag
Kathrinvdm

Liebe Kollegen, ich wünsche ein schönes Wochenende!  :-)

 

Und falls Ihr Lust habt, das nächste Rätsel mit mir zu lösen, dann lest weiter, ansonsten – einfach ignorieren und den freien Tag genießen. 

 

Ich bin in den letzten Zügen mit dem oben beschriebenen Projekt, am Montag sollen die Daten in den Druck gehen. Pünktlich zur Freigabe-Deadline kam dann noch eine neue Herausforderung. Das Dokument hatte in früheren Versionen die unterschiedlichen Gebührentabellenarten mit einem Farbcode hinterlegt. Es gab drei unterschiedliche Farben, je nach Gebühr. In dem Dokument, welches ich zur Bearbeitung erhalten habe, waren alle ehemals farbigen Flächen einheitlich hellgrau hinterlegt und auch in der Farbpalette des Dokumentes existiert nur Schwarz als angelegte Farbe, kein Blau, kein Gelb, kein Grün weit und breit, was ich als Indiz dafür werte, dass die Farben wirklich gründlich aus dieser Datei getilgt wurden – warum auch immer!

 

Nun habe ich drei Arten von Flächen, die ich einfärben muss:

 

1) Die Headlines, die über eine (wie Ralf ermittelt hat) Absatzlinie farbig hinterlegt sind

Dieses Thema habe ich gelöst, indem ich das Absatzformat dreimal kopiert und die Farben in die gewünschten Werte geändert habe. Anschließend habe ich die Formate entsprechend des Farbcodes neu zugewiesen.

 

2) Die jeweils erste Zeile der Tabellen, die vollständig hinterlegt sein soll

3) Eine weitere Zeile der Tabellen, in der mehr Text steht und in der die einzelnen Zeile abwechselnd weiß und farbig hinterlegt sind

 

Was die Punkte 2 und 3 angeht: ich weiß, in welchen Menüfenstern ich diese Werte jeweils anlegen, beziehungsweise ändern kann. Aber meine Frage an Euch wäre jetzt: Kann ich das irgendwie automatisieren – wäre da Grep die Lösung? Ich hätte im Prinzip gerne ein Absatzformat für die Tabellen, welches die Farbigkeit bequem per Mausklick steuert. Gibt’s das? 

 

Liebe Grüße, 

Kathrin  :-)

Link zum Beitrag
bertel

Ich kenn das Projekt jetzt leider nicht – helfen eventuell die Flächenoptionen weiter? Da kannst du wechselnde (und andere benutzerdefinierte) Flächenfarben einstellen …

 

post-14085-0-10926000-1420884598_thumb.p

 

Diese Einstellungen kannst du auch in Formate > Tabellenformate zuweisen, dann kannst du eine gesamte Tabelle mit 1 Klick formatieren. Und du hast ja auch noch die Formate > Zellenformate, damit due einzelne Zellen abweichend mit 1 Klick formatieren kannst.

Link zum Beitrag
Kathrinvdm

Huhu bertel, danke!

Das meinte ich oben (habe es vermutlich nicht richtig beschrieben): Wie und wo es im einzelnen geht, weiß ich. Aber ich würde das gerne als Formatvorlage anlegen, welche ich der Tabellenzelle dann nur noch mit einem Klick zuweisen muss. Ich habe hundert Seiten Tabellen und würde so ungern für jede einzelne die Parameter in den Einstellungen ändern müssen. Mir schwebt ein schickes »Tabellenzellenformat Farben« vor. ;-)  

Link zum Beitrag
ThierryM

Mir schwebt ein schickes »Tabellenzellenformat Farben« vor. ;-)

dann leg es dir doch einfach an :-)

shift + f9 öffnet das tabellen-bedienfeld. dort gibt es einen reiter ›zellenformate‹, wo du ein für alle mal dein(e) zellenformat(e) definieren kannst. zuweisen lassen die sich vermutlich am schnellsten mit strg + enter (wenn der cursor in der betreffenden zelle steht). dann öffnet sich das ›schnell anwenden‹-menü. dort musst du auf den pfeil neben dem blitz klicken, ›zellenformate‹ anhaken (und am besten alle andere häkchen entfernen) und im suchfeld daneben den namen deines formats eingeben. ab dann kannst du, wenn du dieses fenster mit strg + enter öffnest, mit enter das format zuweisen. es ist bei dieser arbeitsweise sinnvoll, erst ein format überall zuzuweisen, wo es hinmuss, dann das nächste – und nicht durcheinander, weil du dann immer wieder einen neuen formatnamen eingeben musst.

Link zum Beitrag
Kathrinvdm

Oh wow – das klingt genau wie das, was ich brauche! :biglove:

 

Ich habe bisher noch nie mit so einer Flut von Tabellen gearbeitet, deswegen sind meine diesbezüglichen InDesign-Kenntnisse eher rudimentär. Tausend Dank Thierry, ich widme mich dem jetzt gleich mal!  

Link zum Beitrag
bertel

Oh wow – das klingt genau wie das, was ich brauche! :biglove:

:tuschel: Kleiner Tipp: Das ist genau das, was ich oben auch geschrieben hatte:

Diese Einstellungen kannst du auch in Formate > Tabellenformate zuweisen, dann kannst du eine gesamte Tabelle mit 1 Klick formatieren. Und du hast ja auch noch die Formate > Zellenformate, damit du einzelne Zellen abweichend mit 1 Klick formatieren kannst.

 

Ich persönlich mag das Schnell-Anwenden-Bedienfeld nicht, ich lege immer einen Tastatur-Shortcut für jedes Format an. Je nach Geschmack führen hier viele Wege nach Rom :-)

Link zum Beitrag
bertel

Das kann ich bei Tabellen und deren Formatierung bestens nachvollziehen. Als ich mit dem Thema am Anfang war, hatte ich noch nicht mal den Schlauch gesehen, auf dem ich stand  :gimmifive:   :trost:

Link zum Beitrag

Diskutiere mit …

Du kannst jetzt schreiben und dich später registrieren. Wenn du bereits einen Account hast, melde dich an, um von deinem Account aus zu schreiben.
Hinweis: Dein Beitrag muss von einem Moderator zunächst freigeschaltet werden.

Gast
Auf dieses Thema antworten ...

×   Du hast formatierten Text eingefügt.   Restore formatting

  Only 75 emoji are allowed.

×   Dein Link wurde automatisch eingebettet.   Einbetten rückgängig machen und als Link darstellen

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

<p>Graublau Sans Pro von Georg Seifert — ein MyFonts-Bestseller</p>
<p>Graublau Sans Pro von Georg Seifert — ein MyFonts-Bestseller</p>
<p>Graublau Sans Pro von Georg Seifert — ein MyFonts-Bestseller</p>
<p>Graublau Sans Pro von Georg Seifert — ein MyFonts-Bestseller</p>
<p>Graublau Sans Pro von Georg Seifert — ein MyFonts-Bestseller</p>
<p>Graublau Sans Pro von Georg Seifert — ein MyFonts-Bestseller</p>
×
×
  • Neu erstellen...

Hinweis

Wie die meisten Websites, legt auch Typografie.info Cookies im Browser ab, um die Bedienung der Seite zu verbessern. Sie können die Cookie-Einstellungen des Browsers anpassen. Anderenfalls akzeptieren Sie bitte die Speicherung von Cookies. Weitere Details in der Datenschutzerklärung