Jump to content
Unsere freundliche Community freut sich auf deine Fragen …

FontLab Probleme mit Anführungszeichen

Zur besten Antwort springen Gelöst von catfonts,

Empfohlene Beiträge

ConanDoyle

Hallo zusammen, 

 

ich habe folgendes Problem: 

Ich habe eine Font in FontLab Studio 5 erstellt (Mac)und diese exportiert (.ttf). Soweit alles kein Problem und die Schrift verhält sich beim Testen wie gewollt. Habe die Schrift zwei Freunden zum Testen gegeben und hier hat auch fast alles geklappt. Lediglich das Benutzen der Anführungszeichen führte zu Problemen. Der eine erhält immer nur Anführungszeichen unten und der andere erhält erst das Anführungszeichen unten und beim zweiten (welches oben kommen sollte) kommt nur ein leeres Zeichen ohne Inhalt. Beide benutzten auch einen Mac zum Testen. 

Habe danach bei mir geschaut und hier läuft alles normal. Erst unten, dann oben. Wie es sein sollte. 

 

Da ich kein Experte mit dem Programm bin, habe ich nur ein bisschen an den Einstellungen und Exportoptionen rumtesten können, das Problem allerdings nicht beheben können. Unicode müsste passen (201E+F).

 

Vielleicht hat jemand von euch eine Lösung für das Problem. 

 

Wenn ihr noch Sachen wissen müsst, einfach nachfragen. 

 

Vielen Dank und Gruß, 

Christopher 

 

Link zu diesem Kommentar
catfonts

Sind alle 6 Codeplätze für typografische Anführungsstriche belegt? also 201A, 201E, 2018, 2019 201C und 201D?

 

Wenn nicht, es ist möglich, dass deine Tester da andereRegions-Einstellungen haben, und dann von dir noch unbelegte Codeplätze angezeigt werden.

 

201F ist eine eher ungewöhnliche Form als gespiegelte "Doppel-9" und eher wenig in Fonts enthalten, üblicher ist hierfür 201C

Link zu diesem Kommentar
ConanDoyle

Vielen Dank für deine Antwort!

Lediglich 201C+D sind noch mit Anführungszeichen belegt. Ich werde die anderen noch auffüllen und testen lassen und mich dann nochmal melden. 

 

Gruß, 
Christopher 

Link zu diesem Kommentar
  • Beste Antwort
catfonts

Das, was du dort als "Schgließendes deutsches Anführungszeichen" gewählt hast, war ohnehin das falsche Zeichen. U+201F (und davon die Einzel-Form U+201B sind eigentlichg ja als obenstehende öffnende Anführungszeichen gedacht und hat die Form wire kleine, gespiegelte Ziffern 9. Mir ist derezeit keine Sprache bekannt, welches diese Anführungszeichen überhaupt verwendet (sicher gibt es die irgendwo)

 

Unser öffnendes Anführungszeichen nach deiuschem Stil ist ja wuasi ein "Doppel-Komma" also in der Form der Zioffer 9, das dazu gehörende schließende Zeichen hat dann eine um 180° gedrehte Form, also wie hochgestellte kleine Ziffern 6. -dies wäre im Englischen System, das ur Anbführungszeichjen oben nutzt dann doret das öffnende Anführungszeichen - also damit die Bezeichnung "Left Double Quotation Mark" U+201C. Hierzu das schließende wäre dann das "Right Double Quotation Mark" U+201D, welches wir, genau wie eben U+201F in Deutschland nicht verwenden.

 

Hier eine mal eben schnell gebaute Übersicht:

post-22079-0-60191700-1399807145_thumb.j:

  • Gefällt 1
Link zu diesem Kommentar
ConanDoyle

Vielen Dank für deine Hilfe und das Schaubild. Es lag an der fehlenden bzw. falschen Belegung der Felder!
 

Gruß, 

Christopher 

 

Kann geclosed werden. 

Link zu diesem Kommentar

Erstelle ein Benutzerkonto oder melde dich an, um zu kommentieren

Du musst ein Benutzerkonto haben, um einen Kommentar verfassen zu können

Benutzerkonto erstellen

Neues Benutzerkonto für unsere Community erstellen. Es ist einfach!

Neues Benutzerkonto erstellen

Einloggen

Du hast bereits ein Benutzerkonto? Melde dich hier an.

Jetzt anmelden

Unsere Partner

FDI Type Foundry besuchen
Schriftlizenzierung, einfach gemacht.
Hier beginnt deine kreative Reise.
Mit über 130.000 Fonts der größte Schriften-Shop im Internet.
FDI Altmeister jetzt kostenlos herunterladen und nutzen …
×
×
  • Neu erstellen...

🍪 Hinweis:

Wir benutzen funktionale Cookies.