Jump to content
Registriere dich bei Typografie.info und schalte sofort alle Mitgliederfunktionen (einschließlich des Download-Portals) frei …

Könnt Ihr mir bei meinem Kerning-Problem helfen?

Empfohlene Beiträge

Leo Pardo

Hallo liebe Schrift-Designer und Experten,

 

ich designe meine eigenen Fonts, bin aber anscheinend noch Anfänger, vor allem was das Kerning angeht.

 

Hier mein Problem: Ich versuche einen Font auf DaFont hochzuladen und kriege die Antwort, das es nicht geht, wegen Kerning-Problemen.
(Hat jemand ähnliche Erfahrungen mit Dafont gehabt?)

Tatsächlich scheint es Kerning-Schwierigkeiten in meinem Font zu geben, da das Kerning zwar von den Adobe-Programmen erkannt wird (CS5),

aber von meinem MS Office Word 2007 nicht. (Auch wenn ich Unterschneidung bzw. Kerning unter Schriftart/Zeichenabstand aktiviere.)

 

Ich habe nur ein einfaches Kerning mit Kerning-Paaren angelegt. Ich hatte diese Probleme sowohl als ich das Kerning im Fontself Plug-In von Illustrator erstellt habe, sowie beim Erstellen des Kernings in Birdfont.

Ich habe bereits versucht zu checken was los ist in dem ich den Font (ttf) in FontForge geöffnet habe. Dort ist auf jeden Fall ein GPOS lookup mit den von mir erstellten Paaren vorhanden. Soviel kann ich bisher sagen.

 

Man merkt wahrscheinlich, dass ich diesbezüglich wirklich ein Anfänger bin, ich könnte von daher eure Hilfe wirklich gebrauchen.
Euer Forum ist wirklich Klasse und gefällt mir auch optisch sehr gut und ich bin froh, dass ich es gefunden habe.

Bitte beachtet bei euren Antworten, dass ich mir die ganzen teureren Schriftprogramme als Lösung für das Problem nicht leisten kann (Sollte ja auch so alles mit FontForge etc. funktionieren.)

 

Kann mir Irgendjemand Helfen?

Vielen Dank im voraus!

Gerne beschreibe ich das Problem weiter, falls Ihr noch mehr Infos braucht.

 

Leo

 

Link zu diesem Kommentar
catfonts

Und dann, bei der Font-Erstellung mehr an Bleisatz-Zeiten denken. Hier waren tatsächliche Unterschneidungen eine schwierige Sache, und daher wurde das "Fleisch" also der nicht druckende Raum neben der eigentlichen Glyphe eben so gestaltet, dass eine Unterschneidung der absolute Sonderfall ist. Also erst einmal an den "Sidebearings" feilen, bis die Schrift schon ohne jedes Kerning (nahezu) sehr gut aussieht.

Erst dann bei den verbleibenden Problemfällen (z.B. AV AW, AY, AT LV...) kernen - und hier am besten über ein Klassenkerning, also Glyphen, die rechts, links oder auf beiden Seiten eine ähnliche Form haben in Klassen vereinigen, sodass es nur noch dann ein Kerningpaar zwischen diesen Klassen oder einer Klasse und einer Einzelglyphe  entsteht.

 

Häufig sehe ich Anfänger-Schriften, bei denen das Fleisch bei allen Glyphen erst einmal gleich eingestellt wurde, und dann jede Glyphe mit praktisch jeder anderen jeweils 2 Kerningpaare bilden. Hierdurch entsteht eine riesige Kerningtabelle, die dann zu solchen Fehlermeldungen führt.

  • Gefällt 2
Link zu diesem Kommentar
Leo Pardo

Ja das ist ein sehr guter Tipp, vielen Dank. Aber dass ich zu viele Kerning-Paare habe, dürfte nicht die Lösung des Problems sein, oder?

Link zu diesem Kommentar
Leo Pardo
vor 7 Stunden schrieb Ralf Herrmann:

Relevanter Tweet von vor zwei Tagen:

 

Vielen Dank für eure schnellen Antworten. Den unteren Dialog "erweiterte Typografie" habe ich bei mir in Word 2007 gar nicht. Ansonsten war er mir aber bekannt und mein Font reagiert auf die Aktivierung der Unterschneidung nicht.

Link zu diesem Kommentar
Þorsten
vor 56 Minuten schrieb Leo Pardo:

dass ich zu viele Kerning-Paare habe, dürfte nicht die Lösung des Problems sein, oder?

Nö, aber vielleicht der Grund? ;-) Wie viele sind es denn? Dutzende? Hunderte?

Link zu diesem Kommentar
Leo Pardo

Ungefähr 100.
Ich hab mal eine Systemschrift aufgemacht und da waren es ungefähr genauso viele Kerning-Paare.

Und die funktioniert.

Link zu diesem Kommentar
Buchlayout
vor 20 Stunden schrieb Leo Pardo:

Tatsächlich scheint es Kerning-Schwierigkeiten in meinem Font zu geben, da das Kerning zwar von den Adobe-Programmen erkannt wird (CS5), aber von meinem MS Office Word 2007 nicht. (Auch wenn ich Unterschneidung bzw. Kerning unter Schriftart/Zeichenabstand aktiviere.) 

Ich bin kein Kerning-Fachmann, weiß aber, dass die Wordfamilie erst ab Version 2010 für Windows erweiterte Features der OT-Fonts verarbeiten kann, vermutlich dann auch erst das OT-Kerning. Insofern mal mit einem aktuelleren Word probieren.

  • Gefällt 1
Link zu diesem Kommentar
Leo Pardo

Vielen Dank auch für diese Antwort.
Ich hab es jetzt in einem Word von 2011 probiert und alles so aktiviert, wie Ralf Herrmann es freundlicher Weise gezeigt hatte,
aber leider immer noch keine Reaktion meiner Schrift.

Auf einer anderen Seite ( http://id-tourism.de/fontlab/info.html ) konnte ich lesen, das Word und einige andere Programme gar keine Kerning-Paare auslesen.
Ist der Tipp von Catfonts oben dann vielleicht die einzige Möglichkeit?
Haben Kerningklassen größere Chancen von den Programmen gelesen zu werden?

Warum funktioniert es bei den Systemschriften?

Link zu diesem Kommentar
catfonts
vor 2 Stunden schrieb Leo Pardo:

Warum funktioniert es bei den Systemschriften?

Das erinnert mich an meine Erfahrungen und meine Tests mit MS Word im Zusammenhang mit OpenType-Funktionen, und meinem Verdacht, dass die Word-Programmierer es nicht hinbekommen haben, diese Daten aus den Fonts auszulesen, und dafür dann die entsprechenden Werte der Systemschriften gleich in den Word-Programmcode selbst aufgenommen haben.

 

Das war nämlich in der Zeit, wo Microsoft zum ersten mal mit der Unterstützung von OpenType-Funktionen warb, und dann empfahl, diese erweiterten Typografie-Funktionen doch gleich mal an eine der Systemschriften auszuprobieren. Mit der Systemschrift hat das dann auch ganz prima funktioniert...

Ich habe daraufhin eine meiner Schriften, die einen vergleichbaren Zeichenumfang hatte dann mit den OpenType-Funktionen dieser Systemschrift ausgestattet. Was dann in der Vorschau im Fonteditor auch funktionierte. Dann habe ich meine Schrift bei mit installiert und in Word ausprobiert. In der Font-Vorschau funktionierten die Funktionen auch, nur eben nicht im eigentlichen Testfenster. Merkwürdig. in anderer Software, die nachweislich mit OpenType umgehen kann, funktionierte meine Schrift auch.

 

Das musste ich jetzt herausbekommen, also habe ich erst einmal die Systemschrift deinstalliert und meiner Schrift dann intern die Namen der Systemschrift gegeben. Ergebnis: Word akzeptierte mit einmal die OpenType-Funktionen! Huch, wie das jetzt?

Also 2. Versuch: Aus meiner als Systemschrift benannten jetzt alle OpenType-Funktionen herausgelöscht, und das in anderer Software auch überprüft - richtig, keine OpenType-Funktionen mehr in der Schrift.

Also Test in Word... Und oh wunder, hier gingen die OpenType-Funktionen alle noch. Wie denn jetzt das?

 

So habe ich meine angebliche Systemschrift wieder deinstalliert, und dann der echten Systemschrift die OpenType-Funktionen  komplett rausgelöscht. Nach installation dieser verstümmelten Version funktionierten die eigentlich nicht mehr vorhandenen OpenType-Funktionen zwar, wie erwartet in der Vorschau nicht, aber, oh größtes Wunder, im Textfenster noch immer.

 

Möglicherweise hast du bei deinen Metriks und Kerningtabellen in deinem Font ja den gleichen Schummeleffekt von Word und den Systemschriften?

Link zu diesem Kommentar
Leo Pardo

Ich konnte das Problem lösen.

Jetzt funktioniert das Kerning sogar in MS Word 2007.
(Natürlich mit aktivierter Unterschneidung wie im Dialog von Ralf Herrmann oben gezeigt.)

 

Ich habe den Font nochmal mit FontForge exportiert und unter options "old style kern" und "windows compatible kern" aktiviert.

Anscheinend sind diese "old style kern tables" für die Office Programme noch notwendig (eine GPOS  kerning alleine reicht nicht aus).

Vielleicht sind diese Tipps für andere auch hilfreich.

 

Vielen Dank für eure Hilfe!

Leo

  • Gefällt 1
Link zu diesem Kommentar
vor 47 Minuten schrieb Leo Pardo:

Anscheinend sind diese "old style kern tables" für die Office Programme noch notwendig (eine GPOS  kerning alleine reicht nicht aus).

Das glaube ich nicht. Es gab sicher bestimmte Gründe, warum dein GPOS-Kerning nicht benutzt wurde. Aber wenn du mit deiner Lösung zufrieden bist, ist das ja auch in Ordnung. 

Link zu diesem Kommentar
catfonts

Doch doch, der @Leo Pardo hat hier recht, und anscheinend ist er, und ich jetzt auch auf einen weiteren Fontlab 5.2-Bug aufmerksam geworden, denn ich bin die Sache mal durch gegangen, mit einer Schrift, ab der ich gerade am Fummeln bin.

In Fontlab habe ich nämlich die Einstellungen mal kontrolliert, und das mit dem Old Style Kerning so eingestellt:

 

(farbliche Markierung nachträglich im Screenschot eingefügt)kerning.PNG.382705abfa1463a646332320f87395b1.PNG

In Fontlab schaut dann das Kerning bei "Taxi" welches ich gewählt habe, weil dies Teil der Windows-Fontvorschau - Mustertextes ist, so aus, am violetten i erkennt man schon ein Klassen-Kerning:

 

768614023_KerninginFontlab.PNG.f80a92bc7ff2454f65cb907aae0c7b7f.PNG

deutlich zu erkennen die deutliche Ta-Unterschneidung.

 

Dann habe ich den Font mit obiger Einstellung, also  inkl. "old-style non OpenType "kern" table" eingeschaltet auch exportiert. Dann schaut der Font in der Windows-Fontvorschau so aus:

20220606_KeineffektinWindoof.PNG.204483cffe9c5f961318afc62195f14b.PNG

Von einem Kerning ist da nichts zu sehen. (Übrigens genau so, wenn ich die "old-style non OpenType "kern" table" -Option ausgeschaltet habe.

 

Ich habe den Font dann installiert, und mit Taxi in Libre Office angeschaut, das kommt dann so:

292958499_KerninginLibre.PNG.22addd03ddfb6559d3d162b4a78746f5.PNG

Das gibt dann eine gleichförmige, aber insgesamt größere Laufweite, als in der Metriks-Anzeige im Fonteditor. Was LibeOffice da mit den Metriks anstellt, ist mir etwas unklar.

 

Jetzt habe ich dann den Font in Fontforge geöffnet (Schade, das die beiden Programme kein gemeinsames Format für die offenen Quelldaten haben). Dann habe ich in Fontforge folgende Einstellungen für den Truetype-Font-Export getroffen (nach Leos Empfehlung)1283392178_DialogFontforge.png.71b0931d8b7dc66153088729745b3e81.png

(rote Markierung wieder nachträglich geändert)

 

Taxi schaut im Kerning-Fenster von Fontforge übrigens so aus

2060767651_Windows-VorschauFF-Font.PNG.8fe6119aa4ef7047bce90641bd3905f3.PNG

Also hat Fontforge das OpenType-Kerning von FontLab auch lesen können.

Mit obigen Einstellungen schaut dann der der Font in der Windows-Vorschau  auch so - und gut - aus:

2060767651_Windows-VorschauFF-Font.PNG.8fe6119aa4ef7047bce90641bd3905f3.PNG

also tatsächlich wie in Fontforge selbst,  und letztlich passt es auch dann in Libre:

2107480662_FF-FontinLibre.PNG.e906dba84b2aa3ccf2146aeded060ce1.PNG

Wie die Sache in MS-Office dann aussieht, konnte ich leider nicht prüfen, aber ich glaube, um eine generelle Nachbearbeitung in Fontforge komme ich nicht herum.

 

Kerningpaar Ta in Fontforge.PNG

  • Gefällt 1
Link zu diesem Kommentar

Erstelle ein Benutzerkonto oder melde dich an, um zu kommentieren

Du musst ein Benutzerkonto haben, um einen Kommentar verfassen zu können

Benutzerkonto erstellen

Neues Benutzerkonto für unsere Community erstellen. Es ist einfach!

Neues Benutzerkonto erstellen

Einloggen

Du hast bereits ein Benutzerkonto? Melde dich hier an.

Jetzt anmelden

Unsere Partner

Mit über 130.000 Fonts der größte Schriften-Shop im Internet.
Entdecke hunderte Font-Sonderangebote.
FDI Type Foundry besuchen
Hier beginnt deine kreative Reise.
Das Typografie-Erklär- und Schaubuch – mit Tipps zur konkreten Umsetzung in Adobe InDesign
×
×
  • Neu erstellen...

🍪 Hinweis:

Wir benutzen funktionale Cookies.