Jump to content
Die besten Typografie-Links bequem per E-Mail erhalten.

Indesign / Spaltenumbruch kontrollieren

Zur besten Antwort springen Gelöst von Diwarnai,

Empfohlene Beiträge

Extrabrandt

Hallo zusammen,

ich komme leider nicht weiter … ich setze eine mehrspaltige Broschüre (in diesem Fall Deutsch und Russisch, aber das ist nicht wichtig, glaube ich) und kriege es nicht hin, einerseitz Schusterjungen/Hurenkinder zu vermeiden, andererseits die Spalten auszunutzen.

Variante 1: Ich verwende die Umbruchoptionen, doch dann werden mehr Zeilen als nötig in die Spalte genommen.
Variante 2: Ich verwende die Umbruchoptionen, dann bekomme ich ein Hurenkind, obwohl in der vorherigen Spalte noch eine Zeile frei ist.

Das taucht ständig auf und kostet mich reichlich Nerven - übersehe ich eine andere Einstellung irgendwo? Oder wo ist mein Fehler?

Ich benutze Indesign 19.0.1 auf einem MacBook Pro mit Venura (13.5.2) und bin sehr dankbar für Hinweise 🙂

Viele Grüße,
Benjamin

Bildschirmfoto 2024-02-02 um 19.25.39.png

Bildschirmfoto 2024-02-02 um 19.24.46.png

Bildschirmfoto 2024-02-02 um 19.23.29.png

Link zu diesem Kommentar
Quarz

Hallo Extrabrandt,

ich löse das Problem, indem ich Zeilen aus- oder eintreibe.
Hierfür gibt es 2 wunderbare Scripte von Sascha Bucher,
denen ich jeweils Shortcuts zugewiesen habe.
Damit macht die Arbeit 'Spaß'
https://www.sabu.ch/artikel/waisen-und-hurenkind

Gruß Quarz

Link zu diesem Kommentar
Diwarnai
vor 41 Minuten schrieb Extrabrandt:

übersehe ich eine andere Einstellung irgendwo?

Ich sehe keine Absatzmarke in der Leerzeile – liegt das daher am "Abstand nach"?

Link zu diesem Kommentar
Extrabrandt
vor 14 Stunden schrieb Quarz:

Hallo Extrabrandt,

ich löse das Problem, indem ich Zeilen aus- oder eintreibe.
Hierfür gibt es 2 wunderbare Scripte von Sascha Bucher,
denen ich jeweils Shortcuts zugewiesen habe.
Damit macht die Arbeit 'Spaß'
https://www.sabu.ch/artikel/waisen-und-hurenkind

Gruß Quarz

Hallo Quarz,

vielen Dank für den Link zu den Skripten, das habe ich bisher manuell gemacht.

Allerdings löst es mein aktuelles Problem nicht, denn im Grunde passt der Absatz ja. Nur möchte Indesign ihn aber unbedingt umbrechen und nimmt die letzen zwei Zeilen mit in die nächste Spalte (s. dritter Screenshot).

Das erscheint mir logisch, wenn ich unter den Umbruchoptionen „Zeilen nicht trennen“ verwende, aber das löst das Problem leider auch nicht...

Grüße,
Benjamin

Link zu diesem Kommentar
Extrabrandt
vor 14 Stunden schrieb Diwarnai:

Ich sehe keine Absatzmarke in der Leerzeile – liegt das daher am "Abstand nach"?

Hallo Dirwarnai,

Es ist ein „Abstand nach“ eingestellt, aber das verursacht nicht das Problem, es bleibt bestehen, auch wenn ich den wegnehme.

Viele Grüße,
Benjamin

Link zu diesem Kommentar
Diwarnai

Da mich solche Probleme reizen: Kannst du ein unverfängliches Beispieldokument zur Verfügung stellen? Sind ja doch ein paar Stellschrauben mehr, die infrage kommen …

Link zu diesem Kommentar
Extrabrandt

Gerne 🙂 Siehe Anhang - ich habe alle Seiten weggeschmissen bis auf die beiden Druckbögen, in denen das Problem auftritt. Die Stelle ist gelb markiert. Übrigens gibt es das Problem nicht nur hier sondern an diversen anderen Stellen im kompletten Dokument nochmal.

Jedenfalls, danke schon mal!

Seiten12-15.indd

Link zu diesem Kommentar
Diwarnai

Im Absatzformat ist ein sehr großer »Abstand danach« eingestellt, nimm den raus. 

Wenn du eine Leerzeile durch einen »Abstand danach« erzeugen willst, geht das wohl grundsätzlich, aber offensichtlich nicht in der Formatvorlage. Vielleicht ein bug, keine Ahnung. In dem speziellen Fall müsstest du aber einen erzwungenen Zeilenumbruch verwenden, da sonst durch den »Abstand danach« und »Zeilen nicht trennen« zwei Zeilen in die nächste Spalte rutschen.

Bildschirmfoto-2024-02-03-um-11-29-49.pn

Link zu diesem Kommentar
Extrabrandt

Tja, wenn’s ein bug ist wäre das natürlich doof ... Es scheint jedenfalls keinen Unterschied zu machen, ob der Abstand danach so groß ist, oder halt kleiner – eine Leerzeile bleibt eine Leerzeile.

Wenn ich den „Abstand danach“ drinlasse, „Zeilen nicht trennen“ aber rausnehme, entsteht ein Hurenkind in der nächsten Spalte. Kann es sein, dass Indesign damit verhindern möchte, dass die Spalte mit einer Leerzeile beginnt, obwohl „Abstand danch“ eine erzwingen würde?

Ich würde dann wohl so vorgehen, dass ich an den Stellen, wo das Problem auftritt, den Abstand danach in einer zweiten Formatvorlage rausnehme, dann klappts. Ist natürlich fehleranfällig, denn sobald sich der Spaltenumbruch ändert, habe ich an der Stelle halt kein Leerzeile mehr.

Vielen Dank jedenfalls!

Link zu diesem Kommentar
  • Beste Antwort
Diwarnai
Geschrieben (bearbeitet)

Der »Abstand nach« gehört zur vorigen Zeile, daher kann der neue Absatz nicht mit einer Leerzeile in der nächsten Spalte anfangen, es gibt ja keine Leerzeile.

Diese Anpassungen von Hand (z. B. Verlängern der Spalte) sind immer nötig, zumindest kenne ich keinen Automatismus, der nur wegen eines Absatzanfangs in einer neuen Spalte den »Abstand nach« weglässt. Wobei diese Anpassungen ja erst ganz zum Schluss passieren, wenn sich am Text nichts mehr ändert.

Ein »Abstand nach: 1 mm« in der Formatvorlage führt zu fehlerhaftem Verhalten.

Ein »Abstand nach: 1 mm« händisch eingegeben führt zu korrektem Verhalten, siehe Screenshot.

Bildschirmfoto-2024-02-03-um-14-27-49.pn

bearbeitet von Diwarnai
Link zu diesem Kommentar
Atelier313

Hallo Extrabrandt,

ich habe mir Deine Textversion angesehen – bei Dir ist in den Umbruchoptionen "Nicht trennen von nächsten 2 Zeilen" eingegeben. Wenn Du das rausnimmst, klappt es doch. Oder habe ich die Dimension des Problems nicht verstanden? Dann verzeih ...

Viele Grüße - Thomas

Bildschirmfoto 2024-02-08 um 10.58.15.png

Link zu diesem Kommentar
Extrabrandt
Geschrieben (bearbeitet)

Hallo Thomas,

an „Zeilen nicht trennen“ habe ich auch als erstes gedacht, aber das führt leider zu keinem guten Ergebnis: Ist die Option aktiv, werden die beiden letzten Zeilen zusammen gehalten und in die nächste Spalte umbrochen, obwohl in der Spalte noch Platz für zwei Zeilen wäre. Ist die Option deaktiviert, springt eine einzele Zeile in die nächste Spalte, aber auch hier ist natürlich eigentlich genug Platz in der ersten Spalte.  (S. Screenshots in meinem ersten Post).

Ich gehe jetzt damit um, wie von Diwarnai empfohlen: Im Absatzformat keinen Abstand danch einstellen, diesen dann aber manuell ergänzen – dann klappt es. Warum? Keine Ahnung …

Viele Grüße,
Benjamin

 

bearbeitet von Extrabrandt
Link zu diesem Kommentar
Quarz

Hallo Extrabrandt,

hast Du mal den Textrahmen etwas höher aufgezogen?

Gruß Quarz

Link zu diesem Kommentar
Extrabrandt

Hallo Quarz, ich hab’ ihn nach unten aufgezogen, meinst Du das (S. Screenshot oben). Dann passen die Zeilen auch in die Spalte wie ich’s möchte, aber leider erst, wenn der Rahmen so weit aufgezogen ist, dass die folgenden Zeilen noch reinpassen.

Viele Grüße,
Benjamin

Link zu diesem Kommentar
Quarz

Hallo Benjamin,

leider kann ich deine id-Dateii nicht öffnen, da ich noch mit ID C6 unteregs bin.
Wenn du nochmal eine idml-Datei posten könntest?

Gruß Quarz

Link zu diesem Kommentar
uswd

Hallo Benjamin,

ich hab grad die Meta nicht installiert und daher sieht dein Musterdokument bei mir anders aus. Aber wenn ich in den Absatzeinstellungen

grafik.png.cc038cb147ca25451d468d1a3e6de625.png

bei Abstand zwischen Absätzen mit gleichem Format »0 mm« eintrage, dann rutschen zwei Zeilen der nächsten Seite hinauf. Ist das, was du gesucht hast?

Ciao
Ulrich

Link zu diesem Kommentar
Extrabrandt
Geschrieben (bearbeitet)

Ich habe jetzt noch etwas an dem Dokument weitergearbeitet, und mir scheint …

@Quarz – das scheint zu klappen! Hurra! Ich denke vor allem „Nicht trennen vor nächsten –0– Zeilen“ wirkt. Den Abstand danach will ich ja haben, und ob da jetzt 1 oder eine krumme Zahl, z. B. 4,586 steht, macht keinen Unterschied.

@Ulrich – Wenn ich den Abstand zwischen Absätzen mit gleichem Format auf null setze, mag es vielleicht an meinen problematischen Stellen funktionieren, aber überall sonst möchte ich den Abstand ja haben.

Danke Euch beiden jedenfalls!

 

bearbeitet von Extrabrandt
Komma ergänzt
Link zu diesem Kommentar
Quarz

Hallo Benjamin,

um auf der sicheren Seite zu sein, stelle ich den 'Abstand nach' immer geringer ein als den Durchschuss.

Gruß Quarz

  • Gefällt 1
Link zu diesem Kommentar
Diwarnai
vor 2 Stunden schrieb Quarz:

für die Lösung gibt es 2 Screenshots.

Das scheint auf Win und Mac unterschiedlich zu sein. Der "Abstand nach: 1 mm" im Format festgelegt führt am Mac ebenfalls zu einem fehlerhaften Ergebnis, siehe meinen Post oben.

Link zu diesem Kommentar

Erstelle ein Benutzerkonto oder melde dich an, um zu kommentieren

Du musst ein Benutzerkonto haben, um einen Kommentar verfassen zu können

Benutzerkonto erstellen

Neues Benutzerkonto für unsere Community erstellen. Es ist einfach!

Neues Benutzerkonto erstellen

Einloggen

Du hast bereits ein Benutzerkonto? Melde dich hier an.

Jetzt anmelden

Unsere Partner

Mit über 130.000 Fonts der größte Schriften-Shop im Internet.
FDI Type Foundry besuchen
Entdecke hunderte Font-Sonderangebote.
Hier beginnt deine kreative Reise.
Tierra Nueva: 4 Schriften basierend auf einer alten Karte von Amerika
×
×
  • Neu erstellen...

🍪 Hinweis:

Wir benutzen funktionale Cookies.